Follow

AMP for Mobile Frequently Asked Questions (FAQ)

AMP for iOS

  1. Q: Where can I find SSB's sample AMP for Mobile Application for iOS?

    A: It can be downloaded here, and instructions for installing the sample app are included on that page.

  2. Q: Can bundles be shared between AMP users?

    A: They cannot. Users should be aware that bundles are account specific. If two users share a computer and a bundle is replaced, test results will be sent to the active iOS report of the current bundle's owner.

  3. Q: I run into an error at runtime "NSForwarding: warning: object %p of class '%s' does not implement methodSignatureForSelector: -- did you forget to declare the superclass of '%s'?".  How can I fix this. 

    A: This can be fixed by navigating to 'Product'>'Scheme'>'Edit Scheme' and opening the 'Run' section, then in the 'Diagnostics' panel, ensure that 'Enable Zombie Objects' is turned off. This should resolve the error.  With additional questions about this, please reach out to ampsupport@ssbbartgroup.com.

AMP for Android

  1. Q: Where can I find SSB's sample AMP for Android application?

    A: It can be downloaded on the AMP for Android Installation Guide page. There are also instructions for how to install the sample app included in that guide.

  2. Q: How do I install AMP for Android on my computer?

    A: Installation instructions for AMP for Android can be found in the AMP for Android Installation Guide.

  3. Q: How do I test my Android app using AMP for Android?

    A: The Testing with AMP for Android page provides instructions for how to conduct testing with the program.

  4. Q: Help! I can't seem to launch AMP for Android to test my app in my testing environment.

    A: Double check to make sure that the appcompat v7 library is installed and active in your testing environment. AMP for Android cannot run without this library, which is added to Eclipse when creating your first Android application. You can learn more about the library here.

    If you do not have appcompat v7 as a library project in your Eclipse workspace, refer to this page for steps required to configure appcompat v7 for Eclipse.

    More instructions on using AMP for Android with appcompat v7 can be found in the AMP for Android Installation Guide.

  5. Q: What do I do if I go to clean my application and run it, but it doesn't work?

    A: If you have already installed appcompat v7, you may have errors in your res folder. If you see a red exclamation point next to your SSBIBMSampleApp drop down, this is an indication of this problem happening in your environment.

    To fix these issues, go to Eclipse Preferences > Android > Build Section and change your Build Output from Verbose to Normal.

    Clean your application again, and then attempt to run it. This should resolve this issue.
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Level Access Support
www.levelaccess.com | 800.889.9659
© 2005 - 2018 - Level Access All rights reserved.
Privacy | Security | Credits | License